Displayports stopped working on 1080ti | PCSPECIALIST

Displayports stopped working on 1080ti

TheNeglectedOne

New member
Been running the same setup for over a year now with 1 HDMI going to a 4k tv and 2 DP to HDMI adapters go 2 different 1080p displays and everything has worked fine, the DP could overheat a little from the card when under heavy load but that is all.
Suddenly i booted my PC yesterday and now none of my 3 display ports will give a signal. the HDMI cables themselves work and ai got a new adapter i case the DP adapter had broken but no luck there. the TV is aware of the connection in its input selection but will always show no signal.
the screens are not showing up in the PC display settings.

I have already attempted updating the graphics card, trying different pci slots, different cables. revertings windows updates and all manor of turing off the pc, displays and taking out and plugging in cables.

At this point im starting to think the graphics card has just broken, but it seems unlikely since the HDMI still works and nothing had changed with the pc since it was last working.

PC Specs:
CaseGAME MAX FALCON BLACK GAMING CASE (RGB LED)
Processor (CPU)AMD Ryzen 7 2700X Eight Core CPU (3.7GHz-4.35GHz/20MB CACHE/AM4)
MotherboardGigabyte X470 AORUS Ultra Gaming: ATX, USB 3.1, SATA 6GBs - RGB Ready
Memory (RAM)32GB Corsair VENGEANCE DDR4 3000MHz (2 x 16GB)
Graphics Card11GB NVIDIA GEFORCE GTX 1080 Ti - HDMI, 3x DP GeForce - GTX VR Ready!
1st Storage Drive1TB WD Blue™ 3D NAND 2.5" SSD, (upto 560MB/sR | 530MB/sW)
2nd Storage Drive3TB SATA-III 3.5" HDD, 6GB/s, 7200RPM, 64MB CACHE
DVD/BLU-RAY Drive24x DUAL LAYER DVD WRITER ±R/±RW/RAM
Power SupplyCORSAIR 650W TXm SERIES™ SEMI-MODULAR 80 PLUS® GOLD, ULTRA QUIET
Power Cable1 x 1 Metre UK Power Cable (Kettle Lead)
Processor CoolingCorsair H100i V2 Hydro Cooler w/ PCS Liquid Series Ultra Quiet Fans
Thermal PasteCOOLER MASTER MASTERGEL MAKER THERMAL COMPOUND
Sound CardONBOARD 6 CHANNEL (5.1) HIGH DEF AUDIO (AS STANDARD)
Wireless/Wired NetworkingWIRELESS 802.11 AC1200 867Mbps/5GHz, 300Mbps/2.4GHz PCI-E CARD
USB/Thunderbolt OptionsMIN. 2 x USB 3.0 & 2 x USB 2.0 PORTS @ BACK PANEL + MIN. 2 FRONT PORTS
Operating SystemGenuine Windows 10 Home 64 Bit - inc. Single Licence
 

Oussebon

Moderator
Moderator
When you say updating the graphics card, if you've not already done this, I'd sweep the drivers with DDU and perform a clean install of the latest drivers.

If that fails, I'd DDU again and try a significantly older version.

 

TheNeglectedOne

New member
Hi Oussebon, thanks for the reply. i have just used the DDU in safe mode and installed the most recent (431.36) and then done it again with the oldest version i could see on the Nvidia Gforce website (419.17) from February.
unfortunately no luck there.

To add aswell i did a system restore back a month when i know everything was working fine and still no dice
 
Last edited:
Top